ПРЕДУПРЕЖДЕНИЕ: в kernel/irq/handle.c - после изменения rootfs, но почему?

Первое, что вам нужно сделать, это использовать easy_install для понижения рейтинга pip:

easy_install-2.7 pip==1.2.1

Я также понизил рейтинг setuptools до версии 3.6, но более поздняя версия может сработать:

easy_install setuptools==3.6

После этого вы должны иметь возможность использовать pip-2.7 для обновления вещей для python-2. 7


Если после этого вы создадите virtualenv и активируете его, у вас будет последняя версия pip, которая опять же ничего не установит:

$ virtualenv-2.7 testvenv
$ source testenv/bin/activate
(testvenv) $ pip --version
pip 1.5.6
(testvenv) $ pip install ruamel.ordereddict
Downloading/unpacking ruamel.ordereddict
  Cannot fetch index base URL https://pypi.python.org/simple/
  ...

Так что повторите трюк с простой установкой (в активированном virtualenv нет необходимости указывать pip-2.7 или easy-install-2.7):

(testvenv) $ easy_install pip==1.2.1
....
(testvenv) $ pip install ruamel.ordereddict
Downloading/unpacking ruamel.ordereddict
   Downloading ruamel.ordereddict-0.4.6.tar.gz (47kB): 47kB downloaded
....
Successfully installed ruamel.ordereddict
Cleaning up...
(testvenv) $
1
22.04.2014, 12:42
1 ответ

Это ошибка где-то в ядре. Она не имеет прямого отношения к изменениям rootfs/initramfs. Это может быть связано с какими-то другими изменениями, которые вы сделали (использовали ли вы те же исходники, ту же самую конфигурацию, тот же компилятор?), или это может быть связано с какой-то временной проблемой, которая выявила скрытую ошибку.

Это предупреждение поступает от handle_irq_event_percpu , а обработчик прерывания предназначен для контроллера Atmel MMC. Вероятно, в этом коде есть ошибка.

Даже если вы не заметили никаких последствий, кроме трассировки, этот вид предупреждений имеет тенденцию указывать на серьезные проблемы, которые могут привести к повреждению данных или, по крайней мере, к блокировке. Отладка - нетривиальна. Учитывая, что это довольно старое ядро, проверьте, нет ли в более поздних версиях этого драйвера исправлений, которые могли бы быть связаны, и по возможности рассмотрите возможность использования более свежего ядра.

1
27.01.2020, 23:52

Теги

Похожие вопросы