Модуль X11 версия ABI не соответствует версии сервера

Оказывается, что это было на самом деле смущающе просто, не уверено, почему я не попробовал это во-первых.

vim +BundleInstall +qall 2&> /dev/null
3
24.04.2014, 11:05
2 ответа

У меня как раз была именно эта проблема. В основном это означает, что драйвер видеоадаптера, в моем случае предоставляемый инструментами Parallels, нуждается в обновлении. Вот все команды, которые я выполнил, включая перенастройку gnome, которая может вам не понадобиться:

    # All as root:

    /etc/init.d/gdm3 stop
    Xorg -configure
    /etc/init.d/gdm3 start

    # Looked in the log file:
    vi /var/log/Xorg.0.log # look for breakage!

    ...  prlvideo ... <-- The parallels video driver.
    (EE) module ABI major version (12) doesn't match server's version (15)

    # So I updated parallels tools:

    mount /dev/cdrom
    mount -o remount,ro,exec /dev/cdrom
    cd /media/cdrom0
    ./install

    # And reconfigured:
    shutdown -r now

    /etc/init.d/gdm3 stop
    Xorg -configure
    /etc/init.d/gdm3 start


    vi /var/log/gdm3/\:0-greeter.log

    # This contained errors about no 3d acceleration so:
    shutdown -h now

    # Added 3d acceleration in the parallels GUI and restarted.

    And it worked :-)
1
27.01.2020, 21:31

Это не всегда так просто, это случилось со мной после неудачной сборки и установки текущей передовой LLVM, потому что текущий передовой Firefox хотел этого. Казалось, что сборка прошла нормально, затем make install не смог найти свежий Clang, поэтому все взорвалось и оставило после себя беспорядок. Просто помните, что dpkg -i всегда работает (предположительно ), поэтому вы можете принудительно установить его поверх неправильной версии.

Версии в моем случае были:

[    46.663] (EE) fbturbo: module ABI major version (23) doesn't match the server's version (24)
[    46.663] (EE) Failed to load module "fbturbo" (module requirement mismatch,0)

Выясните, что вам нужно, затем установите его с помощью dpkg -i . Нужные вам файлы, вероятно, уже находятся в /var/cache/apt/archives. Вы просто переустанавливаете их.

0
27.01.2020, 21:31

Теги

Похожие вопросы