Установить приложения KDE под Gnome?

Другой способ сделать это должно использовать здесь документы:

#!/bin/sh

cat > /etc/pam.d/XXX << 'EOF'
Place whatever
should go in
the file here
EOF

chown root:root /etc/pam.d/XXX  # Or whatever floats your boat
chmod u=r,go= /etc/pam.d/XXX    # Ditto
6
05.04.2014, 19:09
1 ответ
[12154]как Gnome поддерживает KDE приложения?[12155]Не знаю, "поддерживает" ли он их активным способом, но, вероятно, нет причин, по которым Вы не можете использовать их внутри GNOME в любом случае. Многие из них не должны требовать, чтобы KDE был запущенным окружением рабочего стола, и GNOME не будет заботиться об этом.[12156]Как мне правильно установить KDE-приложение в Gnome?[12157]С помощью [1121671]apt[1121672], или любой другой системы управления пакетами, которую вы обычно используете: [1121673]apt-cache поиск okular[1121674]. Если это не сработает, попробуйте [1121675]dpkg -S "*okular*"[1121676].[12158]Более того, иногда мне приходится устанавливать из их исходников последнего выпуска, что я часто не могу сделать.[12159]Если у вас нет на то особых причин, просто используйте доступные пакеты ububtu. Если Вы делаете это, чтобы избежать втягивания во многие другие вещи KDE, то это плохая причина, потому что: [12160]Это просто дисковое пространство, вероятно не более нескольких десятков мегабайт. Или около того.[12161]Вы, вероятно, не сможете обойти это в конце концов, как мы увидим.[12162]чтобы установить последнюю версию Okular из исходников в Ubuntu Gnome, я следую:[12163]Часть этих инструкций заключается в том, чтобы сначала [12164]собрать сам KDE[12165]. Если Вы этого не сделали, возможно, у Вас возникнут некоторые проблемы, которые не могут быть решены простой установкой KDE из [1121687]apt[1121688]. Например, может потребоваться наличие исходных текстов, и если есть какая-то особая причина, по которой Вам нужна эта версия okular для git-репо, это может зависеть от версии KDE для git-репо.[12166]Однако, сначала Вы можете, по крайней мере, попробовать установить пакеты ubuntu. Если это не сработает, просто удалите их и соберите из исходников.[12167]Я не знаю, как указать -DCMAKE_INSTALL_PREFIX[12168]В соответствии с примером на странице, на которую Вы ссылались, это должен быть путь, по которому Вы установили KDE, который Вы собрали. Похоже, что у него есть некоторые значения по умолчанию, которые включают в себя [1121691]/usr/share/kde4/apps[1121692], который, вероятно, будет существовать, если вы попробуете использовать пакеты ubuntu. Точным файлом, который Вам понадобится, будет:[12169], который может быть частью пакета KDE [1121693]-dev[1121694]. [1121695]dpkg -S FindKDE4Internal.cmake[1121696] может помочь, хотя он не удался при установке ubuntu, к которому у меня был доступ. Так как явной рекомендацией для сборки okular является параллельная сборка KDE на системе, то ее может не быть в [1121697] никаком пакете [1121698] ubuntu, в этом случае сначала нужно собрать KDE из исходников.[1121206].
4
27.01.2020, 20:29

Теги

Похожие вопросы