При установке trac - “Trac требует Python 2.5 или позже”

Нажатие CTRL+ALT+F1 должен получить Вас к консоли TTY. Можно войти в систему оттуда и добавить обычного пользователя для себя и т.д. Если это не работает, необходимо будет загрузиться в однопользовательском режиме. Просто выполните шаги здесь и затем добавьте пользователя, использующего синтаксис ниже:

useradd -m -s /bin/bash userName
passwd userName

где userName имя пользователя для создания. Можно затем перезагрузить в нормальный режим, если Вы загрузились в однопользовательском режиме или консолях коммутатора к графической консоли путем удара ALT+F7

2
23.05.2017, 15:40
1 ответ

Проблемой, представленной здесь, является та, которая происходит, когда Вы используете распределение, которое имеет и Python2 и Python3, включенный в его репозиториях. Для разрешения конфликтов более ранним версиям добавили их номера версий к двоичному файлу.

В случае с этим вопросом, нужной версией setuptools поскольку Python v2.6 должен был быть установлен для обеспечения easy_install-2.6 двоичный файл.

Довольный Вы решили его!

1
27.01.2020, 22:23

Теги

Похожие вопросы