Будет ли прекращена поддержка Gnome в 2014 году? [закрыто]

declare, вероятно, не существует в оболочке, определенной вашим shebang - #! /bin/sh.

Попробуйте вместо этого #!/bin/bash.

Причина, по которой сработал sourcing it, заключается в том, что вы уже были в оболочке, поддерживающей declare. Sourcing it не открывал новую оболочку, таким образом не использовал шебанг, который не знает declare.

2
23.04.2014, 02:56
0 ответов

Теги

Похожие вопросы